Public vulnerability disclosure

CVE-2025-0131

GlobalProtect App: Incorrect Privilege Management Vulnerability in OPSWAT MetaDefender Endpoint Security SDK

publishedCWE-266

An incorrect privilege management vulnerability in the OPSWAT MetaDefender Endpoint Security SDK used by the Palo Alto Networks GlobalProtect™ app on Windows devices allows a locally authenticated non-administrative Windows user to escalate their privileges to NT AUTHORITY\SYSTEM. However, execution requires that the local user also successfully exploits a race condition, which makes this vulnerability difficult to exploit.

Technical severity7.1 highCVSS 4.0 · CNA: palo_alto
Published2025-05-14Source updated 2026-11-03
Collected2026-11-032 attributed sources

Fixes and workarounds

Fix

This issue is fixed in MetaDefender Endpoint Security SDK 4.3.4451 on Windows, and all later MetaDefender Endpoint Security SDK versions on Windows. To mitigate this issue in the GlobalProtect App on Windows update to one of the listed versions (these versions include the updated MetaDefender Endpoint Security SDK): Version Suggested Solution GlobalProtect App 6.3 on WindowsUpgrade to 6.3.3 or laterGlobalProtect App 6.2 on Windows Upgrade to 6.2.8 or later GlobalProtect App 6.1 on Windows Upgrade to 6.2.8 or later or 6.3.3 or later GlobalProtect App 6.0 on Windows Upgrade to 6.2.8 or later or 6.3.3 or later GlobalProtect App on macOSNot applicableGlobalProtect App on LinuxNot applicableGlobalProtect App on iOSNot applicableGlobalProtect App on AndroidNot applicableGlobalProtect UWP AppNot applicable

Source: CNA: palo_alto

Workaround

No known workarounds or mitigations exist for this issue.

Source: CNA: palo_alto

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
MetaDefender Endpoint Security SDK
OPSWAT
Platforms: Windows
≥ 4.3.0; < 4.3.4451 (affected, custom); unaffected at 4.3.4451
Other versions: unaffected
CNA: palo_alto

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 7.1
high
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H/AU:N/R:U/V:D/U:AmberCNA: palo_alto

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide