# CVE-2025-0131: GlobalProtect App: Incorrect Privilege Management Vulnerability in OPSWAT MetaDefender Endpoint Security SDK

Status: published. Published: 2025-05-14. Updated: 2026-11-03.

An incorrect privilege management vulnerability in the OPSWAT MetaDefender Endpoint Security SDK used by the Palo Alto Networks GlobalProtect™ app on Windows devices allows a locally authenticated non-administrative Windows user to escalate their privileges to NT AUTHORITY\SYSTEM. However, execution requires that the local user also successfully exploits a race condition, which makes this vulnerability difficult to exploit.

## Remediation

- fix: This issue is fixed in MetaDefender Endpoint Security SDK 4.3.4451 on Windows, and all later MetaDefender Endpoint Security SDK versions on Windows. To mitigate this issue in the GlobalProtect App on Windows update to one of the listed versions (these versions include the updated MetaDefender Endpoint Security SDK):
Version
Suggested Solution
GlobalProtect App 6.3 on WindowsUpgrade to 6.3.3 or laterGlobalProtect App 6.2 on Windows
Upgrade to 6.2.8 or later
GlobalProtect App 6.1 on Windows
Upgrade to 6.2.8 or later or 6.3.3 or later
GlobalProtect App 6.0 on Windows
Upgrade to 6.2.8 or later or 6.3.3 or later
GlobalProtect App on macOSNot applicableGlobalProtect App on LinuxNot applicableGlobalProtect App on iOSNot applicableGlobalProtect App on AndroidNot applicableGlobalProtect UWP AppNot applicable (source: CNA: palo_alto)
- workaround: No known workarounds or mitigations exist for this issue. (source: CNA: palo_alto)

## Affected products and versions

- OPSWAT / MetaDefender Endpoint Security SDK: ≥ 4.3.0; < 4.3.4451 (affected, custom); unaffected at 4.3.4451. Source: CNA: palo_alto; platforms: Windows

## Severity and prioritization

- CVSS 4.0: 7.1 (high); CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H/AU:N/R:U/V:D/U:Amber; source: CNA: palo_alto

- CISA KEV: No listing in collected sources

- EPSS: 0.16% as of 2026-11-03; percentile 4.84%

- SSVC: exploitation none; automatable no; technical impact total; source ADP: CISA-ADP

- Weaknesses: CWE-266

## Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

## References

- https://security.paloaltonetworks.com/CVE-2025-0131 (CNA: palo_alto; third-party-advisory)

- https://www.opswat.com/docs/mdsdk/release-notes/cve-2025-0131 (CNA: palo_alto; vendor-advisory)

## Provenance

- CNA: palo_alto: https://www.cve.org/CVERecord?id=CVE-2025-0131; retrieved 2026-11-03; source updated 2026-11-03

- FIRST EPSS: https://api.first.org/data/v1/epss?cve=CVE-2025-0131; retrieved 2026-11-03; source updated Not reported

Revision: 422c9bde67c6bfd903a23f62e43f6c427e37706294c9746bd0388fd6c116ee85

Canonical: https://y2.dev/cve/CVE-2025-0131

## Agent and API access

Public CVE pages, Markdown, and JSON are free to read without an account or API key.

- Public catalog: https://y2.dev/cve/index.json. Follow nextCursor with the same search, filters, sort, and limit (1–100). A null cursor marks the end.

- WebMCP: search_cve_disclosures, get_cve_disclosure, get_cve_page_markdown, get_y2_cve_access. Available in compatible browsers.

- Cyber API: https://api.y2.dev/api/v2/cyber/cves and https://api.y2.dev/api/v2/cyber/cves/{cveId}.

- Y2 Pro or Elite: create a workspace API key with the intel:cyber scope and send Authorization: Bearer <Y2_API_KEY>. Setup: https://y2.dev/docs/api/create-key.

- x402: Pay per request without an account or API key. Omit Authorization, read the HTTP 402 PAYMENT-REQUIRED challenge, validate its current requirements, and retry with PAYMENT-SIGNATURE through an authorized payment client. These browser tools never make payments. Guide: https://y2.dev/docs/api/x402.

- OpenAPI: https://y2.dev/api/openapi.yaml. Agent access metadata: https://y2.dev/cve/agent.json.

Collected public records only. Check source status for coverage and freshness.