CVE-2024-58351
Flowise - Remote Code Execution via overrideConfig Parameter
Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.
Fixes and workarounds
Fix
flowise (npm): OSV reports a fixed version 2.1.4. Check the advisory for supported release branches.
Source: OSV GHSA-5cph-wvm9-45gjAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| Flowise Flowise flowise
npm |
≥ 0; < 2.1.4 (affected, semver) 2.1.4 (unaffected, semver) Other versions: unaffected |
CNA: VulnCheck |
flowiseflowise
npm |
≥ 0; < 2.1.4 (affected, semver); OSV events: introduced 0; fixed 2.1.4Source events (semver)
Other versions: unaffected |
OSV GHSA-5cph-wvm9-45gj |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 4.0 / 9.3 critical |
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA: VulnCheck |
| 3.1 / 9.8 critical |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA: VulnCheck |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gjCNA: VulnCheck · vendor-advisory
- https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameterCNA: VulnCheck · third-party-advisory
- https://github.com/advisories/GHSA-5cph-wvm9-45gjOSV / GitHub Security Advisories · advisory
- https://osv.dev/vulnerability/GHSA-5cph-wvm9-45gjOSV / GitHub Security Advisories · osv
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.