{"affected":[{"defaultStatus":"unaffected","ecosystem":"npm","packageName":"flowise","product":"Flowise","source":"CNA: VulnCheck","vendor":"Flowise","versions":[{"lessThan":"2.1.4","status":"affected","version":"0","versionType":"semver"},{"status":"unaffected","version":"2.1.4","versionType":"semver"}]},{"defaultStatus":"unaffected","ecosystem":"npm","packageName":"flowise","product":"flowise","source":"OSV GHSA-5cph-wvm9-45gj","vendor":"","versions":[{"events":[{"introduced":"0"},{"fixed":"2.1.4"}],"lessThan":"2.1.4","status":"affected","version":"0","versionType":"semver"}]}],"cveId":"CVE-2024-58351","cwes":["CWE-94"],"description":"Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.","epss":{"date":"2026-11-08","percentile":0.51915,"score":0.00662},"exploits":[],"kev":null,"metrics":[{"score":9.3,"severity":"critical","source":"CNA: VulnCheck","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},{"score":9.8,"severity":"critical","source":"CNA: VulnCheck","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}],"modifiedAt":1794146406271,"publishedAt":1781968915759,"references":[{"source":"CNA: VulnCheck","tags":["vendor-advisory"],"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj"},{"source":"CNA: VulnCheck","tags":["third-party-advisory"],"url":"https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameter"},{"source":"OSV / GitHub Security Advisories","tags":["advisory"],"url":"https://github.com/advisories/GHSA-5cph-wvm9-45gj"},{"source":"OSV / GitHub Security Advisories","tags":["osv"],"url":"https://osv.dev/vulnerability/GHSA-5cph-wvm9-45gj"}],"remediation":[{"kind":"fix","source":"OSV GHSA-5cph-wvm9-45gj","text":"flowise (npm): OSV reports a fixed version 2.1.4. Check the advisory for supported release branches.","url":"https://github.com/advisories/GHSA-5cph-wvm9-45gj"}],"revision":"972c08b2febd1688ab15674aad4991fe3d642a85b0e173f1fe6a37ba94a69c01","sources":[{"modifiedAt":1794146406271,"name":"CNA: VulnCheck","retrievedAt":1794146948944,"url":"https://www.cve.org/CVERecord?id=CVE-2024-58351"},{"modifiedAt":1789409704936,"name":"OSV / GitHub Security Advisories","retrievedAt":1794146949513,"url":"https://osv.dev/vulnerability/GHSA-5cph-wvm9-45gj"},{"modifiedAt":null,"name":"FIRST EPSS","retrievedAt":1794150557144,"url":"https://api.first.org/data/v1/epss?cve=CVE-2024-58351"}],"ssvc":{"assessedAt":1782150698603,"automatable":"yes","exploitation":"none","source":"ADP: CISA-ADP","technicalImpact":"total"},"status":"published","title":"Flowise - Remote Code Execution via overrideConfig Parameter","updatedAt":1794150557144}