# CVE-2024-58351: Flowise - Remote Code Execution via overrideConfig Parameter

Status: published. Published: 2026-06-20. Updated: 2026-11-08.

Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.

## Remediation

- fix: flowise (npm): OSV reports a fixed version 2.1.4. Check the advisory for supported release branches. (source: OSV GHSA-5cph-wvm9-45gj) — https://github.com/advisories/GHSA-5cph-wvm9-45gj

## Affected products and versions

- Flowise / Flowise (flowise): ≥ 0; < 2.1.4 (affected, semver); 2.1.4 (unaffected, semver). Source: CNA: VulnCheck
-  / flowise (flowise): ≥ 0; < 2.1.4 (affected, semver); OSV events: introduced 0; fixed 2.1.4. Source: OSV GHSA-5cph-wvm9-45gj

## Severity and prioritization

- CVSS 4.0: 9.3 (critical); CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N; source: CNA: VulnCheck

- CVSS 3.1: 9.8 (critical); CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H; source: CNA: VulnCheck

- CISA KEV: No listing in collected sources

- EPSS: 0.66% as of 2026-11-08; percentile 51.91%

- SSVC: exploitation none; automatable yes; technical impact total; source ADP: CISA-ADP

- Weaknesses: CWE-94

## Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj (CNA: VulnCheck; vendor-advisory)

- https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameter (CNA: VulnCheck; third-party-advisory)

- https://github.com/advisories/GHSA-5cph-wvm9-45gj (OSV / GitHub Security Advisories; advisory)

- https://osv.dev/vulnerability/GHSA-5cph-wvm9-45gj (OSV / GitHub Security Advisories; osv)

## Provenance

- CNA: VulnCheck: https://www.cve.org/CVERecord?id=CVE-2024-58351; retrieved 2026-11-08; source updated 2026-11-08

- OSV / GitHub Security Advisories: https://osv.dev/vulnerability/GHSA-5cph-wvm9-45gj; retrieved 2026-11-08; source updated 2026-09-14

- FIRST EPSS: https://api.first.org/data/v1/epss?cve=CVE-2024-58351; retrieved 2026-11-08; source updated Not reported

Revision: 972c08b2febd1688ab15674aad4991fe3d642a85b0e173f1fe6a37ba94a69c01

Canonical: https://y2.dev/cve/CVE-2024-58351

## Agent and API access

Public CVE pages, Markdown, and JSON are free to read without an account or API key.

- Public catalog: https://y2.dev/cve/index.json. Follow nextCursor with the same search, filters, sort, and limit (1–100). A null cursor marks the end.

- WebMCP: search_cve_disclosures, get_cve_disclosure, get_cve_page_markdown, get_y2_cve_access. Available in compatible browsers.

- Cyber API: https://api.y2.dev/api/v2/cyber/cves and https://api.y2.dev/api/v2/cyber/cves/{cveId}.

- Y2 Pro or Elite: create a workspace API key with the intel:cyber scope and send Authorization: Bearer <Y2_API_KEY>. Setup: https://y2.dev/docs/api/create-key.

- x402: Pay per request without an account or API key. Omit Authorization, read the HTTP 402 PAYMENT-REQUIRED challenge, validate its current requirements, and retry with PAYMENT-SIGNATURE through an authorized payment client. These browser tools never make payments. Guide: https://y2.dev/docs/api/x402.

- OpenAPI: https://y2.dev/api/openapi.yaml. Agent access metadata: https://y2.dev/cve/agent.json.

Collected public records only. Check source status for coverage and freshness.