CVE-2026-93879
Hibernate Validator is affected by an expression language injection vulnerability
Hibernate Validator could allow a remote attacker to cause a denial of service due to uncontrolled resource consumption resulting from improper escaping of user-controlled data in Expression Language (EL) expressions.
Fixes and workarounds
Fix
It is strongly recommended to address the vulnerability by upgrading to the latest version. Upgrade to 6.2.6.Final, 7.0.6.Final, 8.0.6.Final, 9.0.2.Final, 9.1.5.Final or later. For more information see: https://github.com/hibernate/hibernate-validator/security/advisories/GHSA-gv36-fx3r-29p5
Source: CNA: ibmWorkaround
The safe alternative for custom validators is to use `addExpressionVariable` instead of `addMessageParameter` when injecting user-controlled values into EL-enabled messages, as expression variables are bound as typed objects and are never re-parsed as EL expressions.
Source: CNA: ibmFix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: ibmAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| Hibernate Validator IBM |
≥ 5.4.1.Final; ≤ 6.2.5.Final (affected, semver) ≥ 7.0.0.Alpha1; ≤ 7.0.5.Final (affected, semver) ≥ 8.0.0.Alpha1; ≤ 8.0.5.Final (affected, semver) ≥ 9.0.0.Beta2; ≤ 9.0.1.Final (affected, semver) ≥ 9.1.0.Alpha1; ≤ 9.1.4.Final (affected, semver) |
CNA: ibm |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 3.1 / 7.5 high |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA: ibm |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
- https://www.ibm.com/support/pages/node/7293301CNA: ibm · vendor-advisory, patch
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.