# CVE-2026-93879: Hibernate Validator is affected by an expression language injection vulnerability

Status: published. Published: 2026-11-08. Updated: 2026-11-08.

Hibernate Validator could allow a remote attacker to cause a denial of service due to uncontrolled resource consumption resulting from improper escaping of user-controlled data in Expression Language (EL) expressions.

## Remediation

- fix: It is strongly recommended to address the vulnerability by upgrading to the latest version.



Upgrade to 6.2.6.Final, 7.0.6.Final, 8.0.6.Final, 9.0.2.Final, 9.1.5.Final or later.



For more information see:  https://github.com/hibernate/hibernate-validator/security/advisories/GHSA-gv36-fx3r-29p5 (source: CNA: ibm)
- workaround: The safe alternative for custom validators is to use `addExpressionVariable` instead of `addMessageParameter` when injecting user-controlled values into EL-enabled messages, as expression variables are bound as typed objects and are never re-parsed as EL expressions. (source: CNA: ibm)
- fix: The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches. (source: CNA: ibm) — https://www.ibm.com/support/pages/node/7293301

## Affected products and versions

- IBM / Hibernate Validator: ≥ 5.4.1.Final; ≤ 6.2.5.Final (affected, semver); ≥ 7.0.0.Alpha1; ≤ 7.0.5.Final (affected, semver); ≥ 8.0.0.Alpha1; ≤ 8.0.5.Final (affected, semver); ≥ 9.0.0.Beta2; ≤ 9.0.1.Final (affected, semver); ≥ 9.1.0.Alpha1; ≤ 9.1.4.Final (affected, semver). Source: CNA: ibm

## Severity and prioritization

- CVSS 3.1: 7.5 (high); CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H; source: CNA: ibm

- CISA KEV: No listing in collected sources

- EPSS: Not available

- SSVC: Not available

- Weaknesses: CWE-400

## Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

## References

- https://www.ibm.com/support/pages/node/7293301 (CNA: ibm; vendor-advisory, patch)

## Provenance

- CNA: ibm: https://www.cve.org/CVERecord?id=CVE-2026-93879; retrieved 2026-11-08; source updated 2026-11-08

Revision: 94e32913c9d71550140a0356223beb90b2fe4e9f223d045373a683302e814f50

Canonical: https://y2.dev/cve/CVE-2026-93879

## Agent and API access

Public CVE pages, Markdown, and JSON are free to read without an account or API key.

- Public catalog: https://y2.dev/cve/index.json. Follow nextCursor with the same search, filters, sort, and limit (1–100). A null cursor marks the end.

- WebMCP: search_cve_disclosures, get_cve_disclosure, get_cve_page_markdown, get_y2_cve_access. Available in compatible browsers.

- Cyber API: https://api.y2.dev/api/v2/cyber/cves and https://api.y2.dev/api/v2/cyber/cves/{cveId}.

- Y2 Pro or Elite: create a workspace API key with the intel:cyber scope and send Authorization: Bearer <Y2_API_KEY>. Setup: https://y2.dev/docs/api/create-key.

- x402: Pay per request without an account or API key. Omit Authorization, read the HTTP 402 PAYMENT-REQUIRED challenge, validate its current requirements, and retry with PAYMENT-SIGNATURE through an authorized payment client. These browser tools never make payments. Guide: https://y2.dev/docs/api/x402.

- OpenAPI: https://y2.dev/api/openapi.yaml. Agent access metadata: https://y2.dev/cve/agent.json.

Collected public records only. Check source status for coverage and freshness.