Public vulnerability disclosure

CVE-2026-121748

nvm use --delete-prefix lets a project .npmrc choose which file npm rewrites or makes world-writable

publishedCWE-73

Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.27.0 through 0.40.8, when a project's `.npmrc` sets `prefix`, `nvm use` tells the user to run `nvm use --delete-prefix`, which runs `npm config delete prefix` and `npm config delete globalconfig` in the current directory without naming a config file. npm loads the project `.npmrc` before deciding which file to edit, so that file chooses the target: `userconfig=~/.bashrc` makes npm rewrite `~/.bashrc` as ini (corrupting it), and `location=global` with `globalconfig=` leaves the chosen file at mode 0666, which on a shared machine lets another local user write to it. The attacker (the author of a cloned repository or archive, or a local user who can write a shared parent directory) chooses the file but not the bytes written, and no project code runs. Version 0.41.0 no longer lets a project `.npmrc` select which config file `--delete-prefix` edits.

Technical severity1.8 lowCVSS 4.0 · CNA: harborist
Published2026-11-04Source updated 2026-11-04
Collected2026-11-041 attributed source

Fixes and workarounds

Fix

Upgrade to nvm 0.41.0 or later.

Source: CNA: harborist

Workaround

Until upgrading, do not run `nvm use --delete-prefix` in an untrusted project directory; remove the `prefix` setting from your own npmrc files by hand instead.

Source: CNA: harborist

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: harborist

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
nvm
nvm-sh
≥ 0.27.0; < 0.41.0 (affected, semver)
Other versions: unaffected
CNA: harborist

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 1.8
low
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NCNA: harborist
3.1 / 3.6
low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:LCNA: harborist

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide