# CVE-2026-121748: nvm use --delete-prefix lets a project .npmrc choose which file npm rewrites or makes world-writable

Status: published. Published: 2026-11-04. Updated: 2026-11-04.

Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.27.0 through 0.40.8, when a project's `.npmrc` sets `prefix`, `nvm use` tells the user to run `nvm use --delete-prefix`, which runs `npm config delete prefix` and `npm config delete globalconfig` in the current directory without naming a config file. npm loads the project `.npmrc` before deciding which file to edit, so that file chooses the target: `userconfig=~/.bashrc` makes npm rewrite `~/.bashrc` as ini (corrupting it), and `location=global` with `globalconfig=` leaves the chosen file at mode 0666, which on a shared machine lets another local user write to it. The attacker (the author of a cloned repository or archive, or a local user who can write a shared parent directory) chooses the file but not the bytes written, and no project code runs. Version 0.41.0 no longer lets a project `.npmrc` select which config file `--delete-prefix` edits.

## Remediation

- fix: Upgrade to nvm 0.41.0 or later. (source: CNA: harborist)
- workaround: Until upgrading, do not run `nvm use --delete-prefix` in an untrusted project directory; remove the `prefix` setting from your own npmrc files by hand instead. (source: CNA: harborist)
- fix: The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches. (source: CNA: harborist) — https://github.com/nvm-sh/nvm/commit/4049296ca8eef2067517d8cfd5ef5c0e615daa10

## Affected products and versions

- nvm-sh / nvm: ≥ 0.27.0; < 0.41.0 (affected, semver). Source: CNA: harborist

## Severity and prioritization

- CVSS 4.0: 1.8 (low); CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N; source: CNA: harborist

- CVSS 3.1: 3.6 (low); CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L; source: CNA: harborist

- CISA KEV: No listing in collected sources

- EPSS: Not available

- SSVC: Not available

- Weaknesses: CWE-73

## Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

## References

- https://github.com/nvm-sh/nvm/security/advisories/GHSA-ccgf-7gv4-xg5h (CNA: harborist; vendor-advisory)

- https://github.com/nvm-sh/nvm/commit/4049296ca8eef2067517d8cfd5ef5c0e615daa10 (CNA: harborist; patch)

## Provenance

- CNA: harborist: https://www.cve.org/CVERecord?id=CVE-2026-121748; retrieved 2026-11-04; source updated 2026-11-04

Revision: fa6d701274180e3deee33e38ba988a8091820aacb4da1c3ba91ac65093872396

Canonical: https://y2.dev/cve/CVE-2026-121748

## Agent and API access

Public CVE pages, Markdown, and JSON are free to read without an account or API key.

- Public catalog: https://y2.dev/cve/index.json. Follow nextCursor with the same search, filters, sort, and limit (1–100). A null cursor marks the end.

- WebMCP: search_cve_disclosures, get_cve_disclosure, get_cve_page_markdown, get_y2_cve_access. Available in compatible browsers.

- Cyber API: https://api.y2.dev/api/v2/cyber/cves and https://api.y2.dev/api/v2/cyber/cves/{cveId}.

- Y2 Pro or Elite: create a workspace API key with the intel:cyber scope and send Authorization: Bearer <Y2_API_KEY>. Setup: https://y2.dev/docs/api/create-key.

- x402: Pay per request without an account or API key. Omit Authorization, read the HTTP 402 PAYMENT-REQUIRED challenge, validate its current requirements, and retry with PAYMENT-SIGNATURE through an authorized payment client. These browser tools never make payments. Guide: https://y2.dev/docs/api/x402.

- OpenAPI: https://y2.dev/api/openapi.yaml. Agent access metadata: https://y2.dev/cve/agent.json.

Collected public records only. Check source status for coverage and freshness.