Public vulnerability disclosure

CVE-2025-34469

Cowrie < 2.9.0 Unrestricted wget/curl Emulation Enables SSRF-Based DDoS Amplification

publishedCWE-918

Cowrie versions prior to 2.9.0 contain a server-side request forgery (SSRF) vulnerability in the emulated shell implementation of wget and curl. In the default emulated shell configuration, these command emulations perform real outbound HTTP requests to attacker-supplied destinations. Because no outbound request rate limiting was enforced, unauthenticated remote attackers could repeatedly invoke these commands to generate unbounded HTTP traffic toward arbitrary third-party targets, allowing the Cowrie honeypot to be abused as a denial-of-service amplification node and masking the attacker’s true source address behind the honeypot’s IP.

Technical severity6.9 mediumCVSS 4.0 · CNA: VulnCheck
Published2025-12-31Source updated 2026-11-08
Collected2026-11-083 attributed sources

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulnCheck

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulnCheck

Fix

cowrie (PyPI): OSV reports a fixed version 2.9.0. Check the advisory for supported release branches.

Source: OSV GHSA-83jg-m2pm-4jxj

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
Cowrie
Cowrie
cowrie
pypi
≥ 0; < 2.9.0 (affected, semver)
Other versions: unaffected
CNA: VulnCheck
cowrie

cowrie
PyPI
2.7.0 (affected, PyPI)
2.8.0 (affected, PyPI)
2.8.1 (affected, PyPI)
Ecosystem version events: introduced 0; fixed 2.9.0
Source events (ECOSYSTEM)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "2.9.0"
  }
]

Other versions: unaffected
OSV GHSA-83jg-m2pm-4jxj

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 6.9
medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:LCNA: VulnCheck

Exploit evidence

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide