Public vulnerability disclosure

CVE-2024-45409

The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

publishedCWE-347

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Technical severity10.0 criticalCVSS 3.1 · CNA: GitHub_M
Published2024-09-10Source updated 2026-11-03
Collected2026-11-033 attributed sources

Fixes and workarounds

Fix

ruby-saml (RubyGems): OSV reports a fixed version 1.12.3. Check the advisory for supported release branches.

Source: OSV GHSA-jw9c-mfg7-9rx2

Fix

ruby-saml (RubyGems): OSV reports a fixed version 1.17.0. Check the advisory for supported release branches.

Source: OSV GHSA-jw9c-mfg7-9rx2

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
ruby-saml
SAML-Toolkits
< 1.12.3 (affected)
>= 1.13.0, < 1.17.0 (affected)
CNA: GitHub_M
ruby-saml
onelogin
≥ 0; < 1.12.3 (affected, custom)
≥ 1.13.0; < 1.17.0 (affected, custom)
Other versions: unknown
ADP: CISA-ADP
omniauth-saml
omniauth
≥ 0; ≤ 2.1.0 (affected, custom)
Other versions: unknown
ADP: CISA-ADP
ruby-saml

ruby-saml
RubyGems
0.0.5 (affected, RubyGems)
0.0.6 (affected, RubyGems)
0.0.7 (affected, RubyGems)
0.0.8 (affected, RubyGems)
0.2.1 (affected, RubyGems)
0.2.2 (affected, RubyGems)
0.2.3 (affected, RubyGems)
0.3.0 (affected, RubyGems)
0.3.1 (affected, RubyGems)
0.3.2 (affected, RubyGems)
0.3.3 (affected, RubyGems)
0.3.4 (affected, RubyGems)
0.4.0 (affected, RubyGems)
0.4.1 (affected, RubyGems)
0.4.2 (affected, RubyGems)
0.4.3 (affected, RubyGems)
0.4.4 (affected, RubyGems)
0.4.5 (affected, RubyGems)
0.4.6 (affected, RubyGems)
0.4.7 (affected, RubyGems)
0.5.0 (affected, RubyGems)
0.5.1 (affected, RubyGems)
0.5.2 (affected, RubyGems)
0.5.3 (affected, RubyGems)
0.6.0 (affected, RubyGems)
0.7.0 (affected, RubyGems)
0.7.1 (affected, RubyGems)
0.7.2 (affected, RubyGems)
0.7.3 (affected, RubyGems)
0.8.0 (affected, RubyGems)
0.8.1 (affected, RubyGems)
0.8.10 (affected, RubyGems)
0.8.11 (affected, RubyGems)
0.8.12 (affected, RubyGems)
0.8.13 (affected, RubyGems)
0.8.14 (affected, RubyGems)
0.8.15 (affected, RubyGems)
0.8.16 (affected, RubyGems)
0.8.17 (affected, RubyGems)
0.8.18 (affected, RubyGems)
0.8.2 (affected, RubyGems)
0.8.3 (affected, RubyGems)
0.8.4 (affected, RubyGems)
0.8.5 (affected, RubyGems)
0.8.6 (affected, RubyGems)
0.8.7 (affected, RubyGems)
0.8.8 (affected, RubyGems)
0.8.9 (affected, RubyGems)
0.9 (affected, RubyGems)
0.9.1 (affected, RubyGems)
0.9.2 (affected, RubyGems)
0.9.3 (affected, RubyGems)
0.9.4 (affected, RubyGems)
1.0.0 (affected, RubyGems)
1.1.0 (affected, RubyGems)
1.1.1 (affected, RubyGems)
1.1.2 (affected, RubyGems)
1.10.0 (affected, RubyGems)
1.10.1 (affected, RubyGems)
1.10.2 (affected, RubyGems)
1.11.0 (affected, RubyGems)
1.12.0 (affected, RubyGems)
1.12.1 (affected, RubyGems)
1.12.2 (affected, RubyGems)
1.2.0 (affected, RubyGems)
1.3.0 (affected, RubyGems)
1.3.1 (affected, RubyGems)
1.4.0 (affected, RubyGems)
1.4.1 (affected, RubyGems)
1.4.2 (affected, RubyGems)
1.4.3 (affected, RubyGems)
1.5.0 (affected, RubyGems)
1.6.0 (affected, RubyGems)
1.6.1 (affected, RubyGems)
1.6.2 (affected, RubyGems)
1.7.0 (affected, RubyGems)
1.7.1 (affected, RubyGems)
1.7.2 (affected, RubyGems)
1.8.0 (affected, RubyGems)
1.9.0 (affected, RubyGems)
Ecosystem version events: introduced 0; fixed 1.12.3
Source events (ECOSYSTEM)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "1.12.3"
  }
]

Other versions: unaffected
OSV GHSA-jw9c-mfg7-9rx2
ruby-saml

ruby-saml
RubyGems
1.13.0 (affected, RubyGems)
1.14.0 (affected, RubyGems)
1.15.0 (affected, RubyGems)
1.16.0 (affected, RubyGems)
Ecosystem version events: introduced 1.13.0; fixed 1.17.0
Source events (ECOSYSTEM)
[
  {
    "introduced": "1.13.0"
  },
  {
    "fixed": "1.17.0"
  }
]

Other versions: unaffected
OSV GHSA-jw9c-mfg7-9rx2

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 10.0
critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:NCNA: GitHub_M

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide