Public vulnerability disclosure

CVE-2026-82393

pnpm: A tarball dependency's manifest `name` escapes node_modules → arbitrary file write/overwrite on install

publishedCWE-22CWE-73CWE-94

pnpm is a package manager. Prior to 10.34.5 and 11.11.0, pnpm accepts a scoped path traversal in a tarball dependency's package.json manifest name because pnpm11/resolving/npm-resolver/src/pickPackage.ts rejects slash characters only for unscoped names. During pnpm install, the unvalidated name reaches raw path joins in pnpm11/installing/deps-resolver/src/resolvePeers.ts, pnpm11/installing/deps-resolver/src/index.ts, and pnpm11/deps/graph-builder/src/lockfileToDepGraph.ts, causing package extraction outside node_modules and allowing attacker-controlled files to overwrite arbitrary filesystem paths even when --ignore-scripts is used. The overwrite can replace shell startup files, Git hooks, or installed package code and lead to code execution. This issue is fixed in versions 10.34.5, and 11.11.0.

Technical severity7.5 highCVSS 3.1 · CNA: GitHub_M
Published2026-08-31Source updated 2026-11-03
Collected2026-11-044 attributed sources

Fixes and workarounds

Fix

pnpm (npm): OSV reports a fixed version 10.34.5. Check the advisory for supported release branches.

Source: OSV GHSA-vq4v-j7r6-jq4m

Fix

pnpm (npm): OSV reports a fixed version 11.11.0. Check the advisory for supported release branches.

Source: OSV GHSA-vq4v-j7r6-jq4m

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
pnpm
pnpm
< 10.34.5 (affected)
>= 11.0.0, < 11.11.0 (affected)
CNA: GitHub_M
pnpm

pnpm
npm
≥ 0; < 10.34.5 (affected, semver); OSV events: introduced 0; fixed 10.34.5
Source events (semver)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "10.34.5"
  }
]

Other versions: unaffected
OSV GHSA-vq4v-j7r6-jq4m
pnpm

pnpm
npm
≥ 11.0.0; < 11.11.0 (affected, semver); OSV events: introduced 11.0.0; fixed 11.11.0
Source events (semver)
[
  {
    "introduced": "11.0.0"
  },
  {
    "fixed": "11.11.0"
  }
]

Other versions: unaffected
OSV GHSA-vq4v-j7r6-jq4m

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.5
high
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HCNA: GitHub_M
3.1 / 7.5
high
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HNVD: [email protected]

Exploit evidence

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide