Public vulnerability disclosure

CVE-2026-63402

i18next: Shared built-in corruption through inherited-key deepExtend recursion

publishedCWE-471CWE-1321

i18next is an internationalization framework for JavaScript. Prior to version 26.3.4, `deepExtend` in `src/utils.js` checks property existence with the in operator and recurses into inherited built-ins reached through `Object.prototype`. An application must explicitly pass attacker-controlled resource data to `addResourceBundle(lng, ns, data, deep, overwrite)` with both `deep: true` and `overwrite: true`. Source keys such as `hasOwnProperty`, `toString` and `valueOf` can then select shared inherited built-in function objects, and a nested value can overwrite a property of those objects process-wide. For example, making `Object.prototype.hasOwnProperty.call` non-callable causes subsequent uses, including i18next internals, to throw TypeError, resulting in unrecoverable denial of service and limited integrity impact. The `__proto__`/`constructor` guard does not prevent this mechanism because the corruption target is an inherited built-in function rather than the prototype object itself. Default calls without deep merging or with overwrite falsy are unaffected, and no standard i18next backend or integration uses the vulnerable configuration. This issue is distinct from the setPath/key-walking prototype-pollution flaws in i18next-fs-backend (CVE-2026-48713) and i18next-http-middleware (CVE-2026-48714). This issue is fixed in version 26.3.4.

Technical severity5.9 mediumCVSS 3.1 · CNA: GitHub_M
Published2026-10-30Source updated 2026-11-05
Collected2026-11-054 attributed sources

Fixes and workarounds

Fix

i18next (npm): GitHub reports patched versions 26.3.4. Check the advisory for the affected release branch.

Source: GitHub GHSA-6jcc-5g8w-32mx

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
i18next
i18next
< 26.3.4 (affected) CNA: GitHub_M
i18next

i18next
npm
<= 26.3.3 (affected, GitHub advisory range) GitHub GHSA-6jcc-5g8w-32mx

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 5.9
medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:HCNA: GitHub_M
3.1 / 5.9
medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:HNVD: [email protected]

Exploit evidence

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide