Public vulnerability disclosure

CVE-2026-56828

Shopper: read-only team permissions allow administrator creation and permission escalation

publishedCWE-285CWE-862

Shopper is a Headless e-commerce Admin Panel. From 2.8.0 until 2.8.1, three Shopper Livewire admin components retain authorization gaps after the earlier team-settings authorization fix. A staff member with only `view_users` and `access_dashboard` can mutate permissions, create an administrator, or delete roles. In `packages/admin/src/Livewire/Components/Settings/Team/Permissions.php`, `togglePermission` and `removePermission` authorize `view_users` rather than the stronger `access_setting` permission; `packages/admin/resources/views/livewire/components/settings/team/permissions.blade.php` exposes permission IDs in `wire:click` handlers. The attacker can grant arbitrary permissions to the bound role, including `access_setting` on the attacker's own role, or delete permission definitions. In `packages/admin/src/Livewire/SlideOvers/CreateTeamMember.php`, `mount()` and `store()` also accept `view_users`, and the client-selected `role_id` can identify the admin role, allowing creation of a pre-verified administrator with an attacker-chosen password. In `packages/admin/src/Livewire/Pages/Settings/Team/RolePermission.php`, `deleteAction` has no action authorization and is only conditioned on `can_be_removed`, while page access requires `view_users`. Deleting a removable role removes access for assigned users, enabling RBAC denial of service as well as privilege escalation. This issue is fixed in version 2.8.1.

Technical severity8.8 highCVSS 3.1 · CNA: GitHub_M
Published2026-10-28Source updated 2026-11-03
Collected2026-11-033 attributed sources

Fixes and workarounds

Fix

shopper/framework (Packagist): OSV reports a fixed version 2.9.2. Check the advisory for supported release branches.

Source: OSV GHSA-j328-xmgp-j4q3

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
shopper
shopperlabs
>= 2.8.0, < 2.8.1 (affected) CNA: GitHub_M
shopper/framework

shopper/framework
Packagist
v2.8.0 (affected, Packagist)
v2.8.1 (affected, Packagist)
v2.9.0 (affected, Packagist)
v2.9.1 (affected, Packagist)
Ecosystem version events: introduced 2.8.0; fixed 2.9.2
Source events (ECOSYSTEM)
[
  {
    "introduced": "2.8.0"
  },
  {
    "fixed": "2.9.2"
  }
]

Other versions: unaffected
OSV GHSA-j328-xmgp-j4q3

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 8.8
high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HCNA: GitHub_M

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide