Public vulnerability disclosure

CVE-2026-33762

go-git: Missing validation decoding Index v4 files leads to panic

publishedCWE-129

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

Technical severity2.8 lowCVSS 3.1 · CNA: GitHub_M
Published2026-03-31Source updated 2026-11-02
Collected2026-11-034 attributed sources

Fixes and workarounds

Fix

github.com/go-git/go-git/v5 (Go): OSV reports a fixed version 5.17.1. Check the advisory for supported release branches.

Source: OSV GHSA-gm2x-2g9h-ccm8

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
go-git
go-git
< 5.17.1 (affected) CNA: GitHub_M
github.com/go-git/go-git/v5

github.com/go-git/go-git/v5
Go
≥ 0; < 5.17.1 (affected, semver); OSV events: introduced 0; fixed 5.17.1
Source events (semver)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "5.17.1"
  }
]

Other versions: unaffected
OSV GHSA-gm2x-2g9h-ccm8

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

NVD applicability configurations (1)

These expressions retain AND/OR operators, negation, and required environmental products. A listed product is not sufficient to establish exposure when additional conditions apply.

[
  {
    "negate": false,
    "nodes": [
      {
        "cpeMatch": [
          {
            "criteria": "cpe:2.3:a:go-git_project:go-git:*:*:*:*:*:go:*:*",
            "versionEndExcluding": "5.17.1",
            "vulnerable": true
          }
        ],
        "negate": false,
        "operator": "OR"
      }
    ],
    "operator": "OR"
  }
]

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 2.8
low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:LCNA: GitHub_M
3.1 / 2.8
low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:LNVD: [email protected]

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide