{"affected":[{"product":"CockroachDB PostgreSQL for IBM VPC","source":"CNA: ibm","vendor":"IBM","versions":[{"lessThanOrEqual":"26.2.3","status":"affected","version":"26.2.0","versionType":"semver"},{"lessThanOrEqual":"25.4.12","status":"affected","version":"25.4.0","versionType":"semver"},{"lessThanOrEqual":"25.2.20","status":"affected","version":"25.2.0","versionType":"semver"}]}],"cveId":"CVE-2026-18893","cwes":["CWE-269"],"description":"IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to privilege escalation via user-defined function.","epss":null,"exploits":[],"kev":null,"metrics":[{"score":7.1,"severity":"high","source":"CNA: ibm","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"}],"modifiedAt":1794161322430,"publishedAt":1794161296406,"references":[{"source":"CNA: ibm","tags":["vendor-advisory","patch"],"url":"https://www.ibm.com/support/pages/node/7293292"}],"remediation":[{"kind":"fix","source":"CNA: ibm","text":"For CockroachDB PostgreSQL for IBM VPC, upgrade to CockroachDB 25.2.20, 25.4.12 or 26.2.3. Download the product versions from IBM Passport Advantage Online."},{"kind":"fix","source":"CNA: ibm","text":"The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.","url":"https://www.ibm.com/support/pages/node/7293292"}],"revision":"14ff0aa419fd533e6501cdfb9db2290b4672e5f486d3a23b202abf25841f7a47","sources":[{"modifiedAt":1794161322430,"name":"CNA: ibm","retrievedAt":1794164926049,"url":"https://www.cve.org/CVERecord?id=CVE-2026-18893"}],"ssvc":null,"status":"published","title":"CockroachDB PostgreSQL for IBM VPC is affected by multiple vulnerabilities","updatedAt":1794164926049}