{"affected":[{"product":"CockroachDB PostgreSQL for IBM VPC","source":"CNA: ibm","vendor":"IBM","versions":[{"lessThanOrEqual":"26.2.3","status":"affected","version":"26.2.0","versionType":"semver"},{"lessThanOrEqual":"25.4.12","status":"affected","version":"25.4.0","versionType":"semver"},{"lessThanOrEqual":"25.2.20","status":"affected","version":"25.2.0","versionType":"semver"}]}],"cveId":"CVE-2026-18546","cwes":["CWE-918"],"description":"IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks.","epss":null,"exploits":[],"kev":null,"metrics":[{"score":5.4,"severity":"medium","source":"CNA: ibm","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"}],"modifiedAt":1794161266823,"publishedAt":1794161124662,"references":[{"source":"CNA: ibm","tags":["vendor-advisory","patch"],"url":"https://www.ibm.com/support/pages/node/7293292"}],"remediation":[{"kind":"fix","source":"CNA: ibm","text":"For CockroachDB PostgreSQL for IBM VPC, upgrade to CockroachDB 25.2.20, 25.4.12 or 26.2.3. Download the product versions from  IBM Passport Advantage Online https://www.ibm.com/software/passportadvantage/pao_customer.html ."},{"kind":"fix","source":"CNA: ibm","text":"The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.","url":"https://www.ibm.com/support/pages/node/7293292"}],"revision":"68b6e5d5643838705c45c9f6950956f4a77bde83fd2bb4e185595ddd98556dad","sources":[{"modifiedAt":1794161266823,"name":"CNA: ibm","retrievedAt":1794164923800,"url":"https://www.cve.org/CVERecord?id=CVE-2026-18546"}],"ssvc":null,"status":"published","title":"CockroachDB PostgreSQL for IBM VPC is affected by multiple vulnerabilities","updatedAt":1794164923800}