Public vulnerability disclosure

CVE-2026-123990

DataEase Chart Data ExtWhere2Str.java ExtWhere2Str.extWhere2sqlOjb sql injection

publishedCWE-89CWE-74

A security vulnerability has been detected in DataEase up to 2.10.27/3.1.0. Affected is the function ExtWhere2Str.extWhere2sqlOjb of the file engine/trans/ExtWhere2Str.java of the component Chart Data Handler. Such manipulation of the argument operator leads to sql injection. The attack may be performed from remote. The exploit has been disclosed publicly and may be used. Upgrading to version 3.2.0 is able to address this issue. Upgrading the affected component is advised. The vendor confirms: "The fix validates the complete compound operator and uses fixed AND / OR keywords instead of concatenating user-controlled logic into SQL."

Technical severity6.9 mediumCVSS 4.0 · CNA: VulDB
Published2026-11-07Source updated 2026-11-07
Collected2026-11-071 attributed source

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulDB

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
DataEase
n/a
2.10.0 (affected)
2.10.1 (affected)
2.10.2 (affected)
2.10.3 (affected)
2.10.4 (affected)
2.10.5 (affected)
2.10.6 (affected)
2.10.7 (affected)
2.10.8 (affected)
2.10.9 (affected)
2.10.10 (affected)
2.10.11 (affected)
2.10.12 (affected)
2.10.13 (affected)
2.10.14 (affected)
2.10.15 (affected)
2.10.16 (affected)
2.10.17 (affected)
2.10.18 (affected)
2.10.19 (affected)
2.10.20 (affected)
2.10.21 (affected)
2.10.22 (affected)
2.10.23 (affected)
2.10.24 (affected)
2.10.25 (affected)
2.10.26 (affected)
2.10.27 (affected)
3.0 (affected)
3.1.0 (affected)
3.2.0 (unaffected)
CNA: VulDB

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 6.9
medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PCNA: VulDB
3.1 / 7.3
high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:CCNA: VulDB
3.0 / 7.3
high
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:CCNA: VulDB
2.0 / 7.5
high
AV:N/AC:L/Au:N/C:P/I:P/A:P/E:POC/RL:OF/RC:CCNA: VulDB

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide