{"affected":[{"defaultStatus":"unaffected","product":"maplibre-gl-js-amplify","source":"CNA: AMZN","vendor":"AWS","versions":[{"lessThan":"4.0.3","status":"affected","version":"0","versionType":"custom"}]}],"cveId":"CVE-2026-121652","cwes":["CWE-79"],"description":"Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl.\n\n\n\nTo remediate this issue, users should upgrade to 4.0.3 or later.","epss":null,"exploits":[],"kev":null,"metrics":[{"score":5.4,"severity":"medium","source":"CNA: AMZN","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},{"score":4.8,"severity":"medium","source":"CNA: AMZN","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},{"score":4.8,"severity":"medium","source":"NVD: ff89ba41-3aa1-4d27-914a-91399e9639e5","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X","version":"4.0"},{"score":5.4,"severity":"medium","source":"NVD: ff89ba41-3aa1-4d27-914a-91399e9639e5","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}],"modifiedAt":1793801409713,"publishedAt":1793731347979,"references":[{"source":"CNA: AMZN","tags":["release-notes","patch"],"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3"},{"source":"CNA: AMZN","tags":["third-party-advisory"],"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9"},{"source":"CNA: AMZN","tags":["vendor-advisory"],"url":"https://aws.amazon.com/security/security-bulletins/2026-167-aws/"},{"source":"ff89ba41-3aa1-4d27-914a-91399e9639e5","tags":[],"url":"https://aws.amazon.com/security/security-bulletins/2026-167-aws/"},{"source":"ff89ba41-3aa1-4d27-914a-91399e9639e5","tags":[],"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3"},{"source":"ff89ba41-3aa1-4d27-914a-91399e9639e5","tags":[],"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9"}],"remediation":[{"kind":"fix","source":"CNA: AMZN","text":"The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.","url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3"}],"revision":"826bc21ed96561719b1a86a32d8cb4544ccb53c4eb862de14ac53b6dc5987480","sources":[{"modifiedAt":1793736060960,"name":"CNA: AMZN","retrievedAt":1793740850422,"url":"https://www.cve.org/CVERecord?id=CVE-2026-121652"},{"modifiedAt":1793801409713,"name":"NVD","retrievedAt":1793816605493,"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-121652"}],"ssvc":{"assessedAt":1793736046727,"automatable":"no","exploitation":"none","source":"ADP: CISA-ADP","technicalImpact":"partial"},"status":"published","title":"Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering","updatedAt":1793816605493}