Y2
Public vulnerability disclosure

CVE-2026-120213

@fastify/http-proxy vulnerable to prefix escape via decoded route parameters

publishedCWE-22CWE-436

@fastify/http-proxy is a Fastify plugin that proxies HTTP requests to an upstream server under a configured prefix. In versions 9.0.0 through 11.6.5, when an application uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path, the plugin substitutes URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value that encodes a path separator together with a fragment or query delimiter therefore decodes into real separators and delimiters that inject extra upstream path segments and strip the mandatory suffix the rewritePrefix was meant to enforce, without using any dot-dot traversal. An unauthenticated remote attacker can use this to reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, server-side request forgery or authorization bypass in the proxied service. The issue is fixed in @fastify/http-proxy 11.6.6, and users should upgrade to 11.6.6 or later. There is no workaround other than upgrading.

Technical severity9.1 criticalCVSS 3.1 · CNA: openjs
Published2026-11-02Source updated 2026-11-02
Collected2026-11-022 attributed sources

Fixes and workarounds

No remediation reported in collected sources.

Missing remediation information is not evidence that no patch exists.

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
@fastify/http-proxy
@fastify/http-proxy
@fastify/http-proxy
npm
≥ 9.0.0; < 11.6.6 (affected, semver)
11.6.6 (unaffected, semver)
Other versions: unaffected
CNA: openjs

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 9.1
critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NCNA: openjs
3.1 / 9.1
critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NNVD: ce714d77-add3-4f53-aff5-83d477b104bb

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References