Public vulnerability disclosure

CVE-2026-119978

Flowise through 3.1.4 Custom Function Sandbox Escape RCE via LocalFileStore

publishedCWE-749

Flowise through 3.1.4 contains a sandbox escape vulnerability that allows authenticated users to execute OS commands by abusing allowlisted langchain and mammoth modules when ALLOW_BUILTIN_DEP=true. Attackers can submit JavaScript to /api/v1/node-custom-function that writes a file into the mammoth package via LocalFileStore and requires it, escaping vm2 as the Flowise process user.

Technical severity9.0 criticalCVSS 4.0 · CNA: VulnCheck
Published2026-10-30Source updated 2026-11-02
Collected2026-11-023 attributed sources

Fixes and workarounds

Fix

flowise (npm): OSV reports a fixed version 3.1.3. Check the advisory for supported release branches.

Source: OSV GHSA-9gvv-qjj3-2p6g

Fix

flowise-components (npm): OSV reports a fixed version 3.1.3. Check the advisory for supported release branches.

Source: OSV GHSA-9gvv-qjj3-2p6g

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
Flowise
FlowiseAI
FlowiseAI/Flowise
github
≥ 0; ≤ 3.1.4 (affected, semver)
Other versions: unaffected
CNA: VulnCheck
flowise

flowise
npm
≥ 0; < 3.1.3 (affected, semver); OSV events: introduced 0; fixed 3.1.3
Source events (semver)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "3.1.3"
  }
]

Other versions: unaffected
OSV GHSA-9gvv-qjj3-2p6g
flowise-components

flowise-components
npm
≥ 0; < 3.1.3 (affected, semver); OSV events: introduced 0; fixed 3.1.3
Source events (semver)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "3.1.3"
  }
]

Other versions: unaffected
OSV GHSA-9gvv-qjj3-2p6g

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 9.0
critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HCNA: VulnCheck
3.1 / 8.5
high
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:HCNA: VulnCheck

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide