CVE-2026-119923
Heap-based Buffer Overflow in Babelfish for PostgreSQL TDS Prelogin Parser
A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a specially crafted malformed TDS prelogin packet to the TDS port. This record consolidates a related NULL-pointer-dereference finding in the same prelogin parser. To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a workaround, restrict network access to the TDS port (default 1433). Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.
Fixes and workarounds
Fix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: AMZNFix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: AMZNFix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: AMZNAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| babelfish-for-postgresql AWS |
≥ 1.0; ≤ 1.5 (affected, custom) ≥ 2.1; ≤ 2.15 (affected, custom) ≥ 3.1; ≤ 3.12 (affected, custom) ≥ 4.0; ≤ 4.8 (affected, custom) ≥ 5.1; ≤ 5.4 (affected, custom) Other versions: unaffected |
CNA: AMZN |
| Amazon Aurora PostgreSQL with Babelfish Amazon |
≥ 1.0.0; < 1.5.5 (affected, custom) ≥ 1.6.0; < 1.17.2 (affected, custom) ≥ 2.0.0; < 2.3.5 (affected, custom) ≥ 2.4.0; < 2.12.4 (affected, custom) ≥ 2.13.0; < 2.13.3 (affected, custom) ≥ 2.14.0; < 2.14.2 (affected, custom) ≥ 2.15.0; < 2.15.2 (affected, custom) ≥ 2.16.0; < 2.16.1 (affected, custom) ≥ 3.0.0; < 3.8.4 (affected, custom) ≥ 3.9.0; < 3.9.4 (affected, custom) ≥ 3.10.0; < 3.10.3 (affected, custom) ≥ 3.11.0; < 3.11.2 (affected, custom) ≥ 3.12.0; < 3.12.2 (affected, custom) ≥ 3.13.0; < 3.13.1 (affected, custom) ≥ 4.0.0; < 4.5.5 (affected, custom) ≥ 4.6.0; < 4.6.3 (affected, custom) ≥ 4.7.0; < 4.7.2 (affected, custom) ≥ 4.8.0; < 4.8.2 (affected, custom) ≥ 4.9.0; < 4.9.1 (affected, custom) ≥ 5.0.0; < 5.1.4 (affected, custom) ≥ 5.2.0; < 5.2.3 (affected, custom) ≥ 5.3.0; < 5.3.2 (affected, custom) ≥ 5.4.0; < 5.4.2 (affected, custom) 5.5.0 (affected, custom) ≥ 6.0.0; < 6.0.2 (affected, custom) Other versions: unaffected |
CNA: AMZN |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 3.1 / 9.8 critical |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA: AMZN |
| 4.0 / 9.3 critical |
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA: AMZN |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_4_10_0__PG_16_14CNA: AMZN · release-notes, patch
- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_5_6_0__PG_17_10CNA: AMZN · release-notes, patch
- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_6_1_0__PG_18_4CNA: AMZN · release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-166-aws/CNA: AMZN · vendor-advisory
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.