Public vulnerability disclosure

CVE-2026-118254

Highcharts Grid: pagination language options are parsed as HTML

publishedCWE-79

Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin when pagination controls render. Exploitation requires pagination to be enabled but does not require additional user interaction. This issue is fixed in 3.2.0.

Technical severity8.6 highCVSS 4.0 · CNA: GitHub_M
Published2026-10-28Source updated 2026-11-03
Collected2026-11-033 attributed sources

Fixes and workarounds

Fix

@highcharts/grid-lite (npm): OSV reports a fixed version 3.2.0. Check the advisory for supported release branches.

Source: OSV GHSA-r5wg-q8fc-p6w2

Fix

@highcharts/grid-pro (npm): OSV reports a fixed version 3.2.0. Check the advisory for supported release branches.

Source: OSV GHSA-r5wg-q8fc-p6w2

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
highcharts
highcharts
< 13.0.0-beta.2 (affected) CNA: GitHub_M
grid-lite
@highcharts
>= 2.0.0, < 3.2.0 (affected) CNA: GitHub_M
grid-pro
@highcharts
>= 2.0.0, < 3.2.0 (affected) CNA: GitHub_M
@highcharts/grid-lite

@highcharts/grid-lite
npm
≥ 2.0.0; < 3.2.0 (affected, semver); OSV events: introduced 2.0.0; fixed 3.2.0
Source events (semver)
[
  {
    "introduced": "2.0.0"
  },
  {
    "fixed": "3.2.0"
  }
]

Other versions: unaffected
OSV GHSA-r5wg-q8fc-p6w2
@highcharts/grid-pro

@highcharts/grid-pro
npm
≥ 2.0.0; < 3.2.0 (affected, semver); OSV events: introduced 2.0.0; fixed 3.2.0
Source events (semver)
[
  {
    "introduced": "2.0.0"
  },
  {
    "fixed": "3.2.0"
  }
]

Other versions: unaffected
OSV GHSA-r5wg-q8fc-p6w2

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 8.6
high
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:NCNA: GitHub_M

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide