Public vulnerability disclosure

CVE-2026-117538

REDAXO before 5.21.0 Reflected XSS via Packages API function Parameter

publishedCWE-79

REDAXO before 5.21.0 contains a reflected cross-site scripting vulnerability in the backend packages API, where the function parameter is concatenated into an error message rendered without HTML escaping. Attackers can lure an authenticated backend user to a crafted link containing a valid CSRF token, executing JavaScript that performs same-origin actions or reads DOM data.

Technical severity2.1 lowCVSS 4.0 · CNA: VulnCheck
Published2026-10-27Source updated 2026-11-04
Collected2026-11-044 attributed sources

Fixes and workarounds

Fix

redaxo/source (Packagist): OSV reports a fixed version 5.21.0. Check the advisory for supported release branches.

Source: OSV GHSA-xq4j-g85q-wf97

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
core
redaxo
≥ 0; < 5.21.0 (affected, semver)
5.21.0 (unaffected, semver)
Other versions: unaffected
CNA: VulnCheck
redaxo/source

redaxo/source
Packagist
5.10.0 (affected, Packagist)
5.10.0-beta1 (affected, Packagist)
5.10.0-beta2 (affected, Packagist)
5.10.1 (affected, Packagist)
5.11.0 (affected, Packagist)
5.11.0-beta1 (affected, Packagist)
5.11.1 (affected, Packagist)
5.11.2 (affected, Packagist)
5.12.0 (affected, Packagist)
5.12.0-beta1 (affected, Packagist)
5.12.0-beta2 (affected, Packagist)
5.12.0-beta3 (affected, Packagist)
5.12.1 (affected, Packagist)
5.13.0 (affected, Packagist)
5.13.0-beta1 (affected, Packagist)
5.13.0-beta2 (affected, Packagist)
5.13.1 (affected, Packagist)
5.13.2 (affected, Packagist)
5.13.3 (affected, Packagist)
5.14.0 (affected, Packagist)
5.14.0-beta1 (affected, Packagist)
5.14.0-beta2 (affected, Packagist)
5.14.1 (affected, Packagist)
5.14.2 (affected, Packagist)
5.14.3 (affected, Packagist)
5.15.0 (affected, Packagist)
5.15.0-beta1 (affected, Packagist)
5.15.1 (affected, Packagist)
5.16.0 (affected, Packagist)
5.16.0-beta1 (affected, Packagist)
5.16.1 (affected, Packagist)
5.17.0 (affected, Packagist)
5.17.1 (affected, Packagist)
5.18.0 (affected, Packagist)
5.18.1 (affected, Packagist)
5.18.2 (affected, Packagist)
5.18.3 (affected, Packagist)
5.19.0 (affected, Packagist)
5.20.0 (affected, Packagist)
5.20.1 (affected, Packagist)
5.20.2 (affected, Packagist)
5.21.0-beta1 (affected, Packagist)
Ecosystem version events: introduced 0; fixed 5.21.0
Source events (ECOSYSTEM)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "5.21.0"
  }
]

Other versions: unaffected
OSV GHSA-xq4j-g85q-wf97

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 2.1
low
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NCNA: VulnCheck
3.1 / 4.1
medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:LCNA: VulnCheck
4.0 / 2.1
low
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XNVD: [email protected]
3.1 / 4.1
medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:LNVD: [email protected]

Exploit evidence

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide