Public vulnerability disclosure

CVE-2026-116687

CKEditor: Cross-site scripting (XSS) in the engine package

publishedCWE-79

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.

Technical severity3.1 lowCVSS 3.1 · CNA: GitHub_M
Published2026-10-27Source updated 2026-11-03
Collected2026-11-033 attributed sources

Fixes and workarounds

Fix

ckeditor5 (npm): OSV reports a fixed version 47.7.4. Check the advisory for supported release branches.

Source: OSV GHSA-v6mg-96c6-gmpq

Fix

@ckeditor/ckeditor5-engine (npm): OSV reports a fixed version 47.7.4. Check the advisory for supported release branches.

Source: OSV GHSA-v6mg-96c6-gmpq

Fix

ckeditor5 (npm): OSV reports a fixed version 48.5.1. Check the advisory for supported release branches.

Source: OSV GHSA-v6mg-96c6-gmpq

Fix

@ckeditor/ckeditor5-engine (npm): OSV reports a fixed version 48.5.1. Check the advisory for supported release branches.

Source: OSV GHSA-v6mg-96c6-gmpq

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
ckeditor5
ckeditor
>= 29.0.0, < 47.7.4 (affected)
>= 48.0.0, < 48.5.1 (affected)
CNA: GitHub_M
ckeditor5

ckeditor5
npm
≥ 29.0.0; < 47.7.4 (affected, semver); OSV events: introduced 29.0.0; fixed 47.7.4
Source events (semver)
[
  {
    "introduced": "29.0.0"
  },
  {
    "fixed": "47.7.4"
  }
]

Other versions: unaffected
OSV GHSA-v6mg-96c6-gmpq
@ckeditor/ckeditor5-engine

@ckeditor/ckeditor5-engine
npm
≥ 29.0.0; < 47.7.4 (affected, semver); OSV events: introduced 29.0.0; fixed 47.7.4
Source events (semver)
[
  {
    "introduced": "29.0.0"
  },
  {
    "fixed": "47.7.4"
  }
]

Other versions: unaffected
OSV GHSA-v6mg-96c6-gmpq
ckeditor5

ckeditor5
npm
≥ 48.0.0; < 48.5.1 (affected, semver); OSV events: introduced 48.0.0; fixed 48.5.1
Source events (semver)
[
  {
    "introduced": "48.0.0"
  },
  {
    "fixed": "48.5.1"
  }
]

Other versions: unaffected
OSV GHSA-v6mg-96c6-gmpq
@ckeditor/ckeditor5-engine

@ckeditor/ckeditor5-engine
npm
≥ 48.0.0; < 48.5.1 (affected, semver); OSV events: introduced 48.0.0; fixed 48.5.1
Source events (semver)
[
  {
    "introduced": "48.0.0"
  },
  {
    "fixed": "48.5.1"
  }
]

Other versions: unaffected
OSV GHSA-v6mg-96c6-gmpq

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 3.1
low
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:NCNA: GitHub_M

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide