Public vulnerability disclosure

CVE-2026-115923

Backstage catalog rules can be bypassed for URL locations using encoded path segments

publishedCWE-22

Backstage is an open framework for building developer portals. Prior to 3.9.2 and from 4.0.0 until 4.0.2, DefaultCatalogRulesEnforcer in @backstage/plugin-catalog-backend compares the raw location.target URL against catalog.rules, while URL readers canonicalize the same URL before fetching it. An authenticated user with catalog.location.create permission can use percent-encoded path segments to make an untrusted URL match a trusted location pattern even though the canonical URL resolves outside that scope. This admits entity content from an untrusted source as trusted, while further downstream consequences depend on deployment configuration. This issue is fixed in versions 3.9.2 and 4.0.2.

Technical severity6.5 mediumCVSS 3.1 · CNA: GitHub_M
Published2026-10-26Source updated 2026-11-02
Collected2026-11-023 attributed sources

Fixes and workarounds

Fix

@backstage/plugin-catalog-backend (npm): OSV reports a fixed version 3.9.2. Check the advisory for supported release branches.

Source: OSV GHSA-w658-mh9p-ww8f

Fix

@backstage/plugin-catalog-backend (npm): OSV reports a fixed version 4.0.2. Check the advisory for supported release branches.

Source: OSV GHSA-w658-mh9p-ww8f

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
backstage
backstage
< 3.9.2 (affected)
>= 4.0.0, < 4.0.2 (affected)
CNA: GitHub_M
@backstage/plugin-catalog-backend

@backstage/plugin-catalog-backend
npm
≥ 0; < 3.9.2 (affected, semver); OSV events: introduced 0; fixed 3.9.2
Source events (semver)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "3.9.2"
  }
]

Other versions: unaffected
OSV GHSA-w658-mh9p-ww8f
@backstage/plugin-catalog-backend

@backstage/plugin-catalog-backend
npm
≥ 4.0.0; < 4.0.2 (affected, semver); OSV events: introduced 4.0.0; fixed 4.0.2
Source events (semver)
[
  {
    "introduced": "4.0.0"
  },
  {
    "fixed": "4.0.2"
  }
]

Other versions: unaffected
OSV GHSA-w658-mh9p-ww8f

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 6.5
medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NCNA: GitHub_M

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide