CVE-2026-115916
vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS)
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the vocabulary size to pass validation. For a tensor-parallel size of one and an exact multiple-of-64 vocabulary, VocabParallelEmbedding.forward does not mask that value before F.embedding uses it, causing a CUDA device-side assertion and terminating the engine. This issue is fixed in version 0.32.0.
Fixes and workarounds
Fix
vllm (PyPI): OSV reports a fixed version 0.32.0. Check the advisory for supported release branches.
Source: OSV GHSA-q97c-p368-75c4Affected products and versions
| Product | Versions | Authority |
|---|---|---|
| vllm vllm-project |
< 0.32.0 (affected) | CNA: GitHub_M |
vllmvllm
PyPI |
0.0.1 (affected, PyPI) 0.1.0 (affected, PyPI) 0.1.1 (affected, PyPI) 0.1.2 (affected, PyPI) 0.1.3 (affected, PyPI) 0.1.4 (affected, PyPI) 0.1.5 (affected, PyPI) 0.1.6 (affected, PyPI) 0.1.7 (affected, PyPI) 0.10.0 (affected, PyPI) 0.10.1 (affected, PyPI) 0.10.1.1 (affected, PyPI) 0.10.2 (affected, PyPI) 0.11.0 (affected, PyPI) 0.11.1 (affected, PyPI) 0.11.2 (affected, PyPI) 0.12.0 (affected, PyPI) 0.13.0 (affected, PyPI) 0.14.0 (affected, PyPI) 0.14.1 (affected, PyPI) 0.15.0 (affected, PyPI) 0.15.1 (affected, PyPI) 0.16.0 (affected, PyPI) 0.17.0 (affected, PyPI) 0.17.1 (affected, PyPI) 0.18.0 (affected, PyPI) 0.18.1 (affected, PyPI) 0.19.0 (affected, PyPI) 0.19.1 (affected, PyPI) 0.2.0 (affected, PyPI) 0.2.1 (affected, PyPI) 0.2.1.post1 (affected, PyPI) 0.2.2 (affected, PyPI) 0.2.3 (affected, PyPI) 0.2.4 (affected, PyPI) 0.2.5 (affected, PyPI) 0.2.6 (affected, PyPI) 0.2.7 (affected, PyPI) 0.20.0 (affected, PyPI) 0.20.1 (affected, PyPI) 0.20.2 (affected, PyPI) 0.21.0 (affected, PyPI) 0.22.0 (affected, PyPI) 0.22.1 (affected, PyPI) 0.23.0 (affected, PyPI) 0.24.0 (affected, PyPI) 0.25.0 (affected, PyPI) 0.25.1 (affected, PyPI) 0.26.0 (affected, PyPI) 0.27.0 (affected, PyPI) 0.27.1 (affected, PyPI) 0.28.0 (affected, PyPI) 0.29.0 (affected, PyPI) 0.3.0 (affected, PyPI) 0.3.1 (affected, PyPI) 0.3.2 (affected, PyPI) 0.3.3 (affected, PyPI) 0.30.0 (affected, PyPI) 0.31.0 (affected, PyPI) 0.4.0 (affected, PyPI) 0.4.0.post1 (affected, PyPI) 0.4.1 (affected, PyPI) 0.4.2 (affected, PyPI) 0.4.3 (affected, PyPI) 0.5.0 (affected, PyPI) 0.5.0.post1 (affected, PyPI) 0.5.1 (affected, PyPI) 0.5.2 (affected, PyPI) 0.5.3 (affected, PyPI) 0.5.3.post1 (affected, PyPI) 0.5.4 (affected, PyPI) 0.5.5 (affected, PyPI) 0.6.0 (affected, PyPI) 0.6.1 (affected, PyPI) 0.6.1.post1 (affected, PyPI) 0.6.1.post2 (affected, PyPI) 0.6.2 (affected, PyPI) 0.6.3 (affected, PyPI) 0.6.3.post1 (affected, PyPI) 0.6.4 (affected, PyPI) 0.6.4.post1 (affected, PyPI) 0.6.5 (affected, PyPI) 0.6.6 (affected, PyPI) 0.6.6.post1 (affected, PyPI) 0.7.0 (affected, PyPI) 0.7.1 (affected, PyPI) 0.7.2 (affected, PyPI) 0.7.3 (affected, PyPI) 0.8.0 (affected, PyPI) 0.8.1 (affected, PyPI) 0.8.2 (affected, PyPI) 0.8.3 (affected, PyPI) 0.8.4 (affected, PyPI) 0.8.5 (affected, PyPI) 0.8.5.post1 (affected, PyPI) 0.9.0 (affected, PyPI) 0.9.0.1 (affected, PyPI) 0.9.1 (affected, PyPI) 0.9.2 (affected, PyPI) Ecosystem version events: introduced 0; fixed 0.32.0 Source events (ECOSYSTEM)
Other versions: unaffected |
OSV GHSA-q97c-p368-75c4 |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 3.1 / 6.5 medium |
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA: GitHub_M |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4CNA: GitHub_M · x_refsource_CONFIRM
- https://github.com/vllm-project/vllm/pull/59491CNA: GitHub_M · x_refsource_MISC
- https://github.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229CNA: GitHub_M · x_refsource_MISC
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0CNA: GitHub_M · x_refsource_MISC
- https://github.com/advisories/GHSA-q97c-p368-75c4OSV / GitHub Security Advisories · advisory
- https://osv.dev/vulnerability/GHSA-q97c-p368-75c4OSV / GitHub Security Advisories · osv
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.