Public vulnerability disclosure

CVE-2026-110245

Langflow OSS is affected by multiple vulnerabilities

publishedCWE-287

IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote attacker to obtain sensitive information due to improper authentication.

Technical severity7.5 highCVSS 3.1 · CNA: ibm
Published2026-10-29Source updated 2026-11-04
Collected2026-11-042 attributed sources

Fixes and workarounds

Fix

IBM strongly recommends addressing the vulnerability now by upgrading Langflow OSS to version 1.12.5. https://pypi.org/project/langflow/1.12.5/ For Langflow OSS versions 1.0.0 - 1.12.4, follow the Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the Langflow OSS installation instructions https://docs.langflow.org/get-started-installation to install version 1.12.5 and test your flows. For deployments using MCP stdio, also apply the configuration controls in Workarounds and Mitigations. This bulletin also discloses fixes delivered in prior releases: CVE-2026-107366 was fixed in version 1.9.0; CVE-2026-18894 was fixed in version 1.11.2; and CVE-2026-77817 was fixed in version 1.11.5. Version 1.12.5 includes these fixes.

Source: CNA: ibm

Workaround

IBM strongly recommends applying the following configuration controls to deployments using MCP stdio in addition to upgrading Langflow OSS to version 1.12.5. These controls do not replace the upgrade. Set LANGFLOW_MCP_SERVER_INTERPRETER_HARDENING=true to reject direct shell-script execution, and set LANGFLOW_CUSTOM_COMPONENT_ADMIN_ONLY=true to block non-admin MCP stdio access. Restart the Langflow service after updating its environment configuration. These restrictions can require changes to existing MCP server launch configurations and limit which users can use MCP stdio. For public workflows, retain the default restriction on custom components. Explicitly enabling LANGFLOW_ALLOW_PUBLIC_CUSTOM_COMPONENTS permits custom component execution and changes the default protection described for CVE-2026-18894. For CVE-2026-77817, upgrading prevents the identified secret disclosure in new flow and project exports. Revoke or rotate any credentials exposed in previously exported files; upgrading does not remove secrets from copies already exported.

Source: CNA: ibm

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: ibm

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
Langflow OSS
IBM
≥ 1.0.0; ≤ 1.12.4 (affected, semver) CNA: ibm

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.5
high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NCNA: ibm

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide