Public vulnerability disclosure

CVE-2025-71379

vllm - Regular Expression Denial of Service in Multiple Components

publishedCWE-1333

vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.

Technical severity5.3 mediumCVSS 4.0 · CNA: VulnCheck
Published2026-06-20Source updated 2026-11-08
Collected2026-11-083 attributed sources

Fixes and workarounds

Fix

vllm (PyPI): OSV reports a fixed version 0.9.0. Check the advisory for supported release branches.

Source: OSV GHSA-j828-28rj-hfhp

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
vllm
vllm
vllm
pypi
≥ 0.6.3; < 0.9.0 (affected, semver)
0.9.0 (unaffected, semver)
Other versions: unaffected
CNA: VulnCheck
vllm

vllm
PyPI
0.6.3 (affected, PyPI)
0.6.3.post1 (affected, PyPI)
0.6.4 (affected, PyPI)
0.6.4.post1 (affected, PyPI)
0.6.5 (affected, PyPI)
0.6.6 (affected, PyPI)
0.6.6.post1 (affected, PyPI)
0.7.0 (affected, PyPI)
0.7.1 (affected, PyPI)
0.7.2 (affected, PyPI)
0.7.3 (affected, PyPI)
0.8.0 (affected, PyPI)
0.8.1 (affected, PyPI)
0.8.2 (affected, PyPI)
0.8.3 (affected, PyPI)
0.8.4 (affected, PyPI)
0.8.5 (affected, PyPI)
0.8.5.post1 (affected, PyPI)
Ecosystem version events: introduced 0.6.3; fixed 0.9.0
Source events (ECOSYSTEM)
[
  {
    "introduced": "0.6.3"
  },
  {
    "fixed": "0.9.0"
  }
]

Other versions: unaffected
OSV GHSA-j828-28rj-hfhp

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
4.0 / 5.3
medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NCNA: VulnCheck
3.1 / 4.3
medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:LCNA: VulnCheck

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide