CVE-2025-71331
Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows
Flowise before 3.0.8 contains a cross-site scripting (XSS) vulnerability caused by insufficient input filtering in chat messages and custom agent functions. An attacker can inject malicious JavaScript by sending an iframe payload (e.g., <iframe src="javascript:alert(document.cookie)">) in a chat box, or by having a custom agent function return an XSS payload from an external website. The injected script executes in the victim's browser, enabling theft of cookies and session data.
Fixes and workarounds
Fix
flowise (npm): OSV reports a fixed version 3.0.8. Check the advisory for supported release branches.
Source: OSV GHSA-4fr9-3x69-36wvAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| Flowise Flowise flowise
npm |
≥ 0; < 3.0.8 (affected, semver) 3.0.8 (unaffected, semver) Other versions: unaffected |
CNA: VulnCheck |
flowiseflowise
npm |
≥ 0; < 3.0.8 (affected, semver); OSV events: introduced 0; fixed 3.0.8Source events (semver)
Other versions: unaffected |
OSV GHSA-4fr9-3x69-36wv |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 4.0 / 5.1 medium |
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N | CNA: VulnCheck |
| 3.1 / 6.1 medium |
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | CNA: VulnCheck |
Exploit evidence
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wv
exploit · ADP: CISA-ADP
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wvCNA: VulnCheck · vendor-advisory
- https://www.vulncheck.com/advisories/flowise-cross-site-scripting-in-chat-messages-and-agent-workflowsCNA: VulnCheck · third-party-advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wvADP: CISA-ADP · exploit
- https://github.com/advisories/GHSA-4fr9-3x69-36wvOSV / GitHub Security Advisories · advisory
- https://osv.dev/vulnerability/GHSA-4fr9-3x69-36wvOSV / GitHub Security Advisories · osv
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.