CVE-2025-71325
picklescan - Detection Bypass via STACK_GLOBAL Opcode Parsing Logic Flaw
picklescan before 0.0.27 contains a parsing logic error in the _list_globals function when handling STACK_GLOBAL opcodes, failing to track arguments in the correct range and allowing malicious pickle files to bypass detection. Attackers can craft pickle files with arguments at position zero to trigger unexpected exceptions and evade security scanning.
Fixes and workarounds
Fix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: VulnCheckFix
picklescan (PyPI): OSV reports a fixed version 0.0.27. Check the advisory for supported release branches.
Source: OSV GHSA-9gvj-pp9x-gcfrAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| picklescan picklescan picklescan
pypi |
≥ 0; < 0.0.27 (affected, semver) 0.0.27 (unaffected, semver) Other versions: unaffected |
CNA: VulnCheck |
picklescanpicklescan
PyPI |
0.0.1 (affected, PyPI) 0.0.10 (affected, PyPI) 0.0.11 (affected, PyPI) 0.0.12 (affected, PyPI) 0.0.13 (affected, PyPI) 0.0.14 (affected, PyPI) 0.0.15 (affected, PyPI) 0.0.16 (affected, PyPI) 0.0.17 (affected, PyPI) 0.0.18 (affected, PyPI) 0.0.19 (affected, PyPI) 0.0.2 (affected, PyPI) 0.0.20 (affected, PyPI) 0.0.21 (affected, PyPI) 0.0.22 (affected, PyPI) 0.0.23 (affected, PyPI) 0.0.24 (affected, PyPI) 0.0.25 (affected, PyPI) 0.0.26 (affected, PyPI) 0.0.3 (affected, PyPI) 0.0.4 (affected, PyPI) 0.0.5 (affected, PyPI) 0.0.6 (affected, PyPI) 0.0.7 (affected, PyPI) 0.0.8 (affected, PyPI) 0.0.9 (affected, PyPI) Ecosystem version events: introduced 0; fixed 0.0.27 Source events (ECOSYSTEM)
Other versions: unaffected |
OSV GHSA-9gvj-pp9x-gcfr |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 4.0 / 9.3 critical |
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA: VulnCheck |
| 3.1 / 9.8 critical |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA: VulnCheck |
Exploit evidence
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-9gvj-pp9x-gcfr
exploit · ADP: CISA-ADP
References
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-9gvj-pp9x-gcfrCNA: VulnCheck · vendor-advisory
- https://github.com/mmaitre314/picklescan/commit/2a8383cfeb4158567f9770d86597300c9e508d0fCNA: VulnCheck · patch
- https://www.vulncheck.com/advisories/picklescan-detection-bypass-via-stack-global-opcode-parsing-logic-flawCNA: VulnCheck · third-party-advisory
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-9gvj-pp9x-gcfrADP: CISA-ADP · exploit
- https://github.com/advisories/GHSA-9gvj-pp9x-gcfrOSV / GitHub Security Advisories · advisory
- https://osv.dev/vulnerability/GHSA-9gvj-pp9x-gcfrOSV / GitHub Security Advisories · osv
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.