CVE-2024-45717
SolarWinds Platform Cross- Site Scripting Vulnerability
The SolarWinds Platform was susceptible to a XSS vulnerability that affects the search and node information section of the user interface. This vulnerability requires authentication and requires user interaction.
Fixes and workarounds
Fix
SolarWinds recommends that customers upgrade to SolarWinds Platform 2024.4.1 as soon as it becomes available.
Source: CNA: SolarWindsAffected products and versions
| Product | Versions | Authority |
|---|---|---|
| SolarWinds Platform SolarWinds |
SolarWinds Platform 2024.4 and prior versions (affected)
Other versions: affected |
CNA: SolarWinds |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 3.1 / 7.0 high |
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L | CNA: SolarWinds |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.