CVE-2024-22051
CommonMarker Integer Overflow Vulnerability
CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability. This vulnerability can result in possibly unauthenticated remote attackers to cause heap memory corruption, potentially leading to an information leak or remote code execution, via parsing tables with marker rows that contain more than UINT16_MAX columns.
Fixes and workarounds
Fix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: CNA: VulnCheckFix
The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.
Source: ADP: CVEFix
commonmarker (RubyGems): OSV reports a fixed version 0.23.4. Check the advisory for supported release branches.
Source: OSV GHSA-fmx4-26r3-wxpfAffected products and versions
| Product | Versions | Authority |
|---|---|---|
commonmarker
gem |
≥ 0; < 0.23.4 (affected, semver)
Other versions: unaffected |
CNA: VulnCheck |
commonmarkercommonmarker
RubyGems |
0.0.1 (affected, RubyGems) 0.1.0 (affected, RubyGems) 0.1.1 (affected, RubyGems) 0.1.2 (affected, RubyGems) 0.1.3 (affected, RubyGems) 0.10.0 (affected, RubyGems) 0.11.0 (affected, RubyGems) 0.12.0 (affected, RubyGems) 0.13.0 (affected, RubyGems) 0.14.0 (affected, RubyGems) 0.14.1 (affected, RubyGems) 0.14.11 (affected, RubyGems) 0.14.12 (affected, RubyGems) 0.14.13 (affected, RubyGems) 0.14.14 (affected, RubyGems) 0.14.15 (affected, RubyGems) 0.14.2 (affected, RubyGems) 0.14.3 (affected, RubyGems) 0.14.4 (affected, RubyGems) 0.14.5 (affected, RubyGems) 0.14.6 (affected, RubyGems) 0.14.7 (affected, RubyGems) 0.14.8 (affected, RubyGems) 0.14.9 (affected, RubyGems) 0.15.0 (affected, RubyGems) 0.16.0 (affected, RubyGems) 0.16.1 (affected, RubyGems) 0.16.2 (affected, RubyGems) 0.16.3 (affected, RubyGems) 0.16.4 (affected, RubyGems) 0.16.5 (affected, RubyGems) 0.16.6 (affected, RubyGems) 0.16.7 (affected, RubyGems) 0.16.8 (affected, RubyGems) 0.17.0 (affected, RubyGems) 0.17.1 (affected, RubyGems) 0.17.10 (affected, RubyGems) 0.17.11 (affected, RubyGems) 0.17.12 (affected, RubyGems) 0.17.13 (affected, RubyGems) 0.17.2 (affected, RubyGems) 0.17.4 (affected, RubyGems) 0.17.5 (affected, RubyGems) 0.17.6 (affected, RubyGems) 0.17.7 (affected, RubyGems) 0.17.7.1 (affected, RubyGems) 0.17.8 (affected, RubyGems) 0.17.9 (affected, RubyGems) 0.18.0 (affected, RubyGems) 0.18.1 (affected, RubyGems) 0.18.2 (affected, RubyGems) 0.19.0 (affected, RubyGems) 0.2.0 (affected, RubyGems) 0.2.1 (affected, RubyGems) 0.20.0 (affected, RubyGems) 0.20.1 (affected, RubyGems) 0.20.2 (affected, RubyGems) 0.21.0 (affected, RubyGems) 0.21.1 (affected, RubyGems) 0.21.2 (affected, RubyGems) 0.22.0 (affected, RubyGems) 0.23.0 (affected, RubyGems) 0.23.1 (affected, RubyGems) 0.23.2 (affected, RubyGems) 0.3.0 (affected, RubyGems) 0.4.0 (affected, RubyGems) 0.4.1 (affected, RubyGems) 0.5.0 (affected, RubyGems) 0.5.1 (affected, RubyGems) 0.6.0 (affected, RubyGems) 0.7.0 (affected, RubyGems) 0.8.0 (affected, RubyGems) 0.9.0 (affected, RubyGems) 0.9.1 (affected, RubyGems) 0.9.2 (affected, RubyGems) Ecosystem version events: introduced 0; fixed 0.23.4 Source events (ECOSYSTEM)
Other versions: unaffected |
OSV GHSA-fmx4-26r3-wxpf |
Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.
CVSS assessments
| Version / score | Vector | Authority |
|---|---|---|
| 3.1 / 9.8 critical |
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | ADP: CISA-ADP |
Exploit evidence
No exploit evidence in collected sources. This is not proof of no exploitation.
References
- https://github.com/github/cmark-gfm/security/advisories/GHSA-mc3g-88wq-6f4xCNA: VulnCheck · vendor-advisory
- https://github.com/gjtorikian/commonmarker/security/advisories/GHSA-fmx4-26r3-wxpfCNA: VulnCheck · vendor-advisory
- https://github.com/gjtorikian/commonmarker/commit/ab4504fd17460627a6ab255bc3c63e8e5fc6aed3CNA: VulnCheck · patch
- https://github.com/advisories/GHSA-fmx4-26r3-wxpfCNA: VulnCheck · vendor-advisory
- https://vulncheck.com/advisories/vc-advisory-GHSA-fmx4-26r3-wxpfCNA: VulnCheck · third-party-advisory
- https://github.com/github/cmark-gfm/security/advisories/GHSA-mc3g-88wq-6f4xADP: CVE · related, x_transferred
- https://github.com/gjtorikian/commonmarker/security/advisories/GHSA-fmx4-26r3-wxpfADP: CVE · vendor-advisory, x_transferred
- https://github.com/gjtorikian/commonmarker/commit/ab4504fd17460627a6ab255bc3c63e8e5fc6aed3ADP: CVE · patch, x_transferred
- https://github.com/advisories/GHSA-fmx4-26r3-wxpfADP: CVE · third-party-advisory, x_transferred
- https://vulncheck.com/advisories/vc-advisory-GHSA-fmx4-26r3-wxpfADP: CVE · third-party-advisory, x_transferred
- https://github.com/advisories/GHSA-fmx4-26r3-wxpfOSV / GitHub Security Advisories · advisory
- https://osv.dev/vulnerability/GHSA-fmx4-26r3-wxpfOSV / GitHub Security Advisories · osv
For agents and automation
Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.
Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.
Endpoints and access details
https://api.y2.dev/api/v2/cyber/cveshttps://api.y2.dev/api/v2/cyber/cves/{cveId}
A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.
For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.