Public vulnerability disclosure

CVE-2024-22047

Audited Log Integrity Errors Due to Race Condition

publishedCWE-362

A race condition exists in Audited 4.0.0 before 5.3.3 that can result in an authenticated user to cause audit log entries to be attributed to another user.

Technical severity3.1 lowCVSS 3.1 · CNA: VulnCheck
Published2024-01-04Source updated 2026-11-08
Collected2026-11-083 attributed sources

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulnCheck

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulnCheck

Fix

audited (RubyGems): OSV reports a fixed version 5.3.3. Check the advisory for supported release branches.

Source: OSV GHSA-hjp3-5g2q-7jww

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority


audited
gem
≥ 4.0.0; < 5.3.3 (affected, semver)
Other versions: unaffected
CNA: VulnCheck
audited

audited
RubyGems
4.0.0 (affected, RubyGems)
4.10.0 (affected, RubyGems)
4.2.0 (affected, RubyGems)
4.2.1 (affected, RubyGems)
4.2.2 (affected, RubyGems)
4.3.0 (affected, RubyGems)
4.4.0 (affected, RubyGems)
4.4.1 (affected, RubyGems)
4.5.0 (affected, RubyGems)
4.6.0 (affected, RubyGems)
4.7.0 (affected, RubyGems)
4.7.1 (affected, RubyGems)
4.8.0 (affected, RubyGems)
4.9.0 (affected, RubyGems)
5.0.0 (affected, RubyGems)
5.0.1 (affected, RubyGems)
5.0.2 (affected, RubyGems)
5.1.0 (affected, RubyGems)
5.2.0 (affected, RubyGems)
5.3.0 (affected, RubyGems)
5.3.1 (affected, RubyGems)
5.3.2 (affected, RubyGems)
Ecosystem version events: introduced 4.0.0; fixed 5.3.3
Source events (ECOSYSTEM)
[
  {
    "introduced": "4.0.0"
  },
  {
    "fixed": "5.3.3"
  }
]

Other versions: unaffected
OSV GHSA-hjp3-5g2q-7jww

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 3.1
low
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:NCNA: VulnCheck

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide