Public vulnerability disclosure

CVE-2024-0241

encoded_id-rails Denial of Service Vulnerability

publishedCWE-400

encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.

Technical severity7.5 highCVSS 3.1 · ADP: CISA-ADP
Published2024-01-04Source updated 2026-11-08
Collected2026-11-083 attributed sources

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: CNA: VulnCheck

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: ADP: CVE

Fix

encoded_id-rails (RubyGems): OSV reports a fixed version 1.0.0.beta2. Check the advisory for supported release branches.

Source: OSV GHSA-3px7-jm2p-6h2c

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority


encoded_id-rails
gem
≥ 0; < 1.0.0.beta2 (affected, custom)
Other versions: unaffected
CNA: VulnCheck
encoded_id-rails

encoded_id-rails
RubyGems
0.1.0 (affected, RubyGems)
0.2.0 (affected, RubyGems)
0.3.0 (affected, RubyGems)
0.3.1 (affected, RubyGems)
0.4.0 (affected, RubyGems)
0.5.0 (affected, RubyGems)
0.6.0 (affected, RubyGems)
0.6.1 (affected, RubyGems)
0.6.2 (affected, RubyGems)
1.0.0.beta1 (affected, RubyGems)
Ecosystem version events: introduced 0; fixed 1.0.0.beta2
Source events (ECOSYSTEM)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "1.0.0.beta2"
  }
]

Other versions: unaffected
OSV GHSA-3px7-jm2p-6h2c

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.5
high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HADP: CISA-ADP

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide