Public vulnerability disclosure

CVE-2022-36062

Grafana folders admin only permission privilege escalation

publishedCWE-281

Grafana is an open-source platform for monitoring and observability. In versions prior to 8.5.13, 9.0.9, and 9.1.6, Grafana is subject to Improper Preservation of Permissions resulting in privilege escalation on some folders where Admin is the only used permission. The vulnerability impacts Grafana instances where RBAC was disabled and enabled afterwards, as the migrations which are translating legacy folder permissions to RBAC permissions do not account for the scenario where the only user permission in the folder is Admin, as a result RBAC adds permissions for Editors and Viewers which allow them to edit and view folders accordingly. This issue has been patched in versions 8.5.13, 9.0.9, and 9.1.6. A workaround when the impacted folder/dashboard is known is to remove the additional permissions manually.

Technical severity7.6 highCVSS 3.1 · CNA: GitHub_M
Published2022-09-22Source updated 2026-11-03
Collected2026-11-044 attributed sources

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: [email protected]

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: af854a3a-2127-422b-91ae-364da2661108

Fix

github.com/grafana/grafana (Go): OSV reports a fixed version 8.5.13. Check the advisory for supported release branches.

Source: OSV GHSA-p978-56hq-r492

Fix

github.com/grafana/grafana (Go): OSV reports a fixed version 9.0.9. Check the advisory for supported release branches.

Source: OSV GHSA-p978-56hq-r492

Fix

github.com/grafana/grafana (Go): OSV reports a fixed version 9.1.6. Check the advisory for supported release branches.

Source: OSV GHSA-p978-56hq-r492

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
grafana
grafana
< 8.5.13 (affected)
>= 9.0.0, < 9.0.9 (affected)
>= 9.1.0, < 9.1.6 (affected)
CNA: GitHub_M
github.com/grafana/grafana

github.com/grafana/grafana
Go
≥ 8.5.0; < 8.5.13 (affected, semver); OSV events: introduced 8.5.0; fixed 8.5.13
Source events (semver)
[
  {
    "introduced": "8.5.0"
  },
  {
    "fixed": "8.5.13"
  }
]

Other versions: unaffected
OSV GHSA-p978-56hq-r492
github.com/grafana/grafana

github.com/grafana/grafana
Go
≥ 9.0.0; < 9.0.9 (affected, semver); OSV events: introduced 9.0.0; fixed 9.0.9
Source events (semver)
[
  {
    "introduced": "9.0.0"
  },
  {
    "fixed": "9.0.9"
  }
]

Other versions: unaffected
OSV GHSA-p978-56hq-r492
github.com/grafana/grafana

github.com/grafana/grafana
Go
≥ 9.1.0; < 9.1.6 (affected, semver); OSV events: introduced 9.1.0; fixed 9.1.6
Source events (semver)
[
  {
    "introduced": "9.1.0"
  },
  {
    "fixed": "9.1.6"
  }
]

Other versions: unaffected
OSV GHSA-p978-56hq-r492

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

NVD applicability configurations (1)

These expressions retain AND/OR operators, negation, and required environmental products. A listed product is not sufficient to establish exposure when additional conditions apply.

[
  {
    "negate": false,
    "nodes": [
      {
        "cpeMatch": [
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "8.5.13",
            "vulnerable": true
          },
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "9.0.9",
            "versionStartIncluding": "9.0.0",
            "vulnerable": true
          },
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "9.1.6",
            "versionStartIncluding": "9.1.0",
            "vulnerable": true
          }
        ],
        "negate": false,
        "operator": "OR"
      }
    ],
    "operator": "OR"
  }
]

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.6
high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:LCNA: GitHub_M
3.1 / 3.8
low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:NNVD: [email protected]
3.1 / 7.6
high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:LNVD: [email protected]

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide