Public vulnerability disclosure

CVE-2022-29546

CVE-2022-29546

published

HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.

Technical severity7.5 highCVSS 3.1 · NVD: [email protected]
Published2022-04-25Source updated 2026-11-02
Collected2026-11-034 attributed sources

Fixes and workarounds

Fix

net.sourceforge.htmlunit:neko-htmlunit (Maven): OSV reports a fixed version 2.61.0. Check the advisory for supported release branches.

Source: OSV GHSA-6jmm-mp6w-4rrg

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
n/a
n/a
Version not specified (affected) CNA: mitre
net.sourceforge.htmlunit:neko-htmlunit

net.sourceforge.htmlunit:neko-htmlunit
Maven
2.21 (affected, Maven)
2.23 (affected, Maven)
2.24 (affected, Maven)
2.25 (affected, Maven)
2.27 (affected, Maven)
2.28 (affected, Maven)
2.30 (affected, Maven)
2.31 (affected, Maven)
2.32 (affected, Maven)
2.33 (affected, Maven)
2.34.0 (affected, Maven)
2.35.0 (affected, Maven)
2.36.0 (affected, Maven)
2.37.0 (affected, Maven)
2.38.0 (affected, Maven)
2.39.0 (affected, Maven)
2.40.0 (affected, Maven)
2.41.0 (affected, Maven)
2.42.0 (affected, Maven)
2.43.0 (affected, Maven)
2.44.0 (affected, Maven)
2.45.0 (affected, Maven)
2.46.0 (affected, Maven)
2.47.0 (affected, Maven)
2.47.1 (affected, Maven)
2.48.0 (affected, Maven)
2.49.0 (affected, Maven)
2.50.0 (affected, Maven)
2.51.0 (affected, Maven)
2.52.0 (affected, Maven)
2.53.0 (affected, Maven)
2.54.0 (affected, Maven)
2.55.0 (affected, Maven)
2.56.0 (affected, Maven)
2.57.0 (affected, Maven)
2.58.0 (affected, Maven)
2.59.0 (affected, Maven)
2.60.0 (affected, Maven)
Ecosystem version events: introduced 0; fixed 2.61.0
Source events (ECOSYSTEM)
[
  {
    "introduced": "0"
  },
  {
    "fixed": "2.61.0"
  }
]

Other versions: unaffected
OSV GHSA-6jmm-mp6w-4rrg

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

NVD applicability configurations (1)

These expressions retain AND/OR operators, negation, and required environmental products. A listed product is not sufficient to establish exposure when additional conditions apply.

[
  {
    "negate": false,
    "nodes": [
      {
        "cpeMatch": [
          {
            "criteria": "cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "2.61.0",
            "vulnerable": true
          }
        ],
        "negate": false,
        "operator": "OR"
      }
    ],
    "operator": "OR"
  }
]

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.5
high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HNVD: [email protected]
2.0 / 5.0
medium
AV:N/AC:L/Au:N/C:N/I:N/A:PNVD: [email protected]

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide