Public vulnerability disclosure

CVE-2022-23552

Grafana stored XSS in FileUploader component

publishedCWE-79

Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch and prior to versions 8.5.16, 9.2.10, and 9.3.4, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible because SVG files weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include either an external URL to a SVG-file containing JavaScript, or use the `data:` scheme to load an inline SVG-file containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.16, 9.2.10, or 9.3.4 to receive a fix.

Technical severity7.3 highCVSS 3.1 · CNA: GitHub_M
Published2023-01-27Source updated 2026-11-03
Collected2026-11-043 attributed sources

Fixes and workarounds

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: [email protected]

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: [email protected]

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: [email protected]

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: [email protected]

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: af854a3a-2127-422b-91ae-364da2661108

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: af854a3a-2127-422b-91ae-364da2661108

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: af854a3a-2127-422b-91ae-364da2661108

Fix

The reporting source identifies this reference as a patch. Check the advisory for affected versions and supported release branches.

Source: af854a3a-2127-422b-91ae-364da2661108

Affected products and versions

Affected products, source version ranges and reporting authorities
ProductVersionsAuthority
grafana
grafana
>= 9.0, < 9.2.10 (affected)
>= 9.3, < 9.3.4 (affected)
>= 8.1, < 8.5.16 (affected)
CNA: GitHub_M

Version ranges are source assertions. Check the vendor advisory and your installed configuration before determining exposure.

NVD applicability configurations (1)

These expressions retain AND/OR operators, negation, and required environmental products. A listed product is not sufficient to establish exposure when additional conditions apply.

[
  {
    "negate": false,
    "nodes": [
      {
        "cpeMatch": [
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "8.5.16",
            "versionStartIncluding": "8.1.0",
            "vulnerable": true
          },
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "9.2.10",
            "versionStartIncluding": "9.0.0",
            "vulnerable": true
          },
          {
            "criteria": "cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:*",
            "versionEndExcluding": "9.3.4",
            "versionStartIncluding": "9.3.0",
            "vulnerable": true
          }
        ],
        "negate": false,
        "operator": "OR"
      }
    ],
    "operator": "OR"
  }
]

CVSS assessments

CVSS scores, vectors and reporting authorities
Version / scoreVectorAuthority
3.1 / 7.3
high
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:NCNA: GitHub_M
3.1 / 5.4
medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NNVD: [email protected]
3.1 / 7.3
high
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:NNVD: [email protected]

Exploit evidence

No exploit evidence in collected sources. This is not proof of no exploitation.

References

For agents and automation

Read public disclosures for free as Markdown or JSON. Compatible browsers also expose native WebMCP tools to search disclosures, read this page, and discover API access.

Use the ontology-linked Cyber API with x402 pay per request, or a Y2 Pro or Elite API key with the intel:cyber scope.

Endpoints and access details

https://api.y2.dev/api/v2/cyber/cves
https://api.y2.dev/api/v2/cyber/cves/{cveId}

A workspace owner or admin can create a Pro or Elite API key. Send Authorization: Bearer <Y2_API_KEY> from your trusted agent runtime.

For x402, omit Authorization and read the HTTP 402 payment challenge before signing a retry. Public browser tools do not make payments.

Agent access JSON · OpenAPI · CVE API guide